Back to overview
Downtime

Experiencing downtime right now

Jun 24, 2026 at 2:24pm UTC
Affected services
9lives.so

Resolved
Jun 24, 2026 at 2:33pm UTC

We seem to have resolved the issue!

Created
Jun 24, 2026 at 2:24pm UTC

New markets are currently not being reported as created. The team is working on it!